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1 Introduction 
 
1.1  About Smart Time 
 
ACTAtek Smart Time Package has been developed to support you in achieving the full 
potential of your business through efficient and accurate rostering, employee attendance and 
reporting system support. 
 
The package can include the supply of ‘specialist’ hardware, software and personalized 
ongoing training and coaching support in the use of the package.  
 
Managers now have the worlds leading tools to assist them achieving the best possible 
financial and operational results in labor management processes. Previously they were only 
available to the largest of companies.  
 
The power of the system is not only in its capacity to accommodate the most complex labor 
variables and structures, but also in its ease of use by the management.  
 
Reliability has been tested over many years in International markets and is proven in highly 
complex operations. Management can be assured of the highest level of functionality even 
under the most difficult situations.  
 
Management and Proprietors have been looking for this competitive edge to achieve their 
financial and life style objectives. ACTAtek Management’s Smart Time package is the answer. 
 
1.2 Features In Smart Time 
 
Smart Time  has many facilities for managing the setup and monitoring of simple and 
complex labour systems . Some of these features include :  
 
Security 
 
1. Multiple Security Access.  
2. Allow User to change their password dynamically.  
3. Allow changing the user’s interface dynamically.  
 
General Setting  
 
1. Define unlimited departments and unlimited levels of sub-departments.  
2. Define unlimited Award Rules.  
3. Define unlimited fix and variable Holidays.  
4. Define unlimited Allowances. 
5. Define unlimited leave types and leave entitlement patterns.  
6. Define unlimited shifts and shift work patterns.  
7. Able to generate roster automatically according to shift pattern. 
8. Able to relate the setting above to the Roster Module.  
   
Employee Information  
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1. Convenient way to search the employee details.  
2. Manage employees’ leave entitlement and history. 
3. Tracking the employee service History.  
4. Storing and retrieve the employee picture.  
   
Rostering  

 
1. Providing the effective security control.  
2. Allow user to prepare their roster within the budget.  
3. Providing the easier way to prepare the roster.  
4. Allow user to define their own roster type or leave types.  
5. Allow multiple (unlimited) shifts in a single day. 
6. Allow user to view the roster by different sort orders. 
7. User can roster the employee with the overtime penalty, over plus penalty and 

allowance and etc.  
8. Able to integrate with the general setting and calculate to work hours accurately.  
9. Allow user to print out all or selected roster information by different layout using 

preferred paper size. 
10. Keeping track of employee unavailability.  
   
Employee Attendance  

 
1. Able to keep track the employee attendance effectively.  
2. Able to trigger out the late comer, early leaving, absent Based on employee attendance 

data.  
3. Able to integrate with the input devices (finger scan, swipe card and etc) effectively.  
   
Authorize Time Keeping  

 
1. Providing the most comprehensive and efficient way in authorized the employee’s time 

keeping. It’s giving the some analysis features in order to allow user to do the 
authorization effectively and accurately.  

2. Providing the different status definition to the different type of the employee’s time 
keeping. e.g. Absent, leave, incomplete, match, critical and etc…  

3. It’s providing the comparison between the actual rostering cost and the time keeping 
cost with the variances added.  

4. Allow user to define the reason in the case of the abnormal time keeping (e.g. Accident, 
machine broke down and etc). 

5. Real-time time keeping information. Able to see employee’s attendance right after the 
employee punched. 

 
Reports  

 
1. Able to print virtually any list view in the software. 
2. Able to print to different paper size and different paper orientations. 
3. Able to print only selected records. 
4. Preview before printing. 
5. Rich reports collection including Time & Attendance Reports, Human Resource Reports, 

Leaves Reports, and Analysis Reports. 
 
   
Others  
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1. Backup or Restore System database.  
2. Automatic daily database backup. 
3. Automatic data importing and analyzing. 
4. Export time attendance data to interface text file and Access database for integration 

purpose. 
5. Fully integrated with MS. Access, SQL Server and etc. 
 
1.3 System Requirement 
 
PC Requirements 
 
Minimum configuration: 
 

• Windows 98 or Greater. 
• Pentium III or greater. 
• 128 Mb of RAM. 
• 100 Mb of hard disk storage. 

 
Recommended configuration: 
 

• Windows XP or Greater. 
• Pentium IV or greater. 
• 256 Mb of RAM. 
• 300 Mb of hard disk storage.  

 
1.4 About This User Manual 
 
Through out this documentation,  
 

• Bold words in this font refer to items in the software or Windows, such as 
a command button, a menu item, a check box, the Windows start button, etc. 

• Italic words in this font refer to example text user may type, a file path, 
etc. 

• Underlined words indicates important notices user should be aware of. 
 
* ACTAtek Management reserves the right to change the software specifications and 
features without advance notice. 
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1.5 User Interface 
 

 
 

 
 

Get ready for a whole new experience. 
 

Smart Time version 5 has a fresh new look and it is easier than ever to use. 
 

Let’s get started!
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2 Frequently Asked Questions 
 
2.1 Installation 
 
• How to install the software? 
 

Insert the Smart Time CDROM into your computer’s CDROM drive. If the CDROM did not 
Autorun, click Start > Run, type [CDROM]:\setup where [CDROM] is your 
computer’s CDROM drive letter. Follow the on-screen instructions to complete the 
installation. 

 
• How to setup the database? 
 

If you are running Microsoft Access Database: 
 
By default the Smart Time installation will setup the database and database connection 
properly. No additional setup work needs to be done. The default Microsoft Access 
database file is located at Installed Path/Database/db.mdb (primary) and 
Installed Path/Database/db_s.mdb (secondary).  
 
However, if you want to create a second database, or you want to move the database to 
another location, you can do so by using the utility Data Source Manager (normally 
located at Start > Programs > TMM Software > Data Source Manager) to 
manage the database connection settings. You can get a copy of an empty database file 
at [Installed Path]/DBScript/db.mdb (primary) and [Installed 
Path]/DBScript/db_s.mdb (secondary). 

 
If you are running Microsoft SQL Server: 

 
1 Use the Microsoft SQL Server database management utility (usually the Enterprise 

Manager) to create two new databases, e.g. Smart Time (for primary database) 
and Smart Time_S (for secondary database).  

2 Run the SQL script located at [Installed Path]/DBScript/MSSQL.sql for the 
primary database.  

3 Run the SQL script located at [Installed Path]/DBScript/MSSQL_S.sql for 
the secondary database.  

4 Run the utility Data Source Manager (normally located at Start > Programs > 
TMM Software > Data Source Manager) and add two new data sources. You 
will need to provide the connection string to connect to the database. Consult your 
database server provider if you don't know the connection string.  

5 Set the primary database source to Primary, and secondary database source to 
Secondary.  
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• How to setup users for the software? 
 

1 Start and login to Smart Time (If you are running Smart Time for the first time, the 
default user name and password are admin and admin).  

2 Select menu Administration > Users Settings.  
3 Click on the Add button. Enter the new user name and password for the new user. 

The new user will be able to change the password after he/she has logged in.  
4 Double click on the newly added user on the list. You can modify the user privileges 

on the popup window.  
 

If you change the settings of your own user, you will have to logout and login again 
before the changes can take effect.  

 
• How to setup the punching devices? 
 

1 Start and login to Smart Time.  
2 Select menu Administration > Device Settings.  
3 Click on the Add button.  
4 Double click on the newly added device on the list. Modify the device settings as you 

want at the popup window and click OK to confirm the changes.  
5 After you have setup the device correctly, you will be able to import punching data 

from the device.  
 
• How to uninstall the software? 
 

1. Go to Control Panel > Add/Remove Programs. 
2. Select the Smart Time from the list, and click the Remove button. 
 
Note: Some Windows Components (such as Microsoft .NET Framework) has also installed 
to your computer during the installation of this software. Please refer to the corresponding 
documentation for uninstallation for these components. 
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2.2 Setting Up 
 
• How to modify company information? 
 

To modify company information, click the Setting menu and select Company 
Information. You can change your company logo, address, phone number, website 
and other information there. Your company name will be printed on the reports. 
 

• How to setup award rules? 
 

To set/modify award rules, click the Setting menu and select Awards Rules. To 
add a new rule, click Add. To modify an existing rule, select the rule and click 
properties. Change the value accordingly, and click OK. 
 

• How to setup holidays? 
 

To setup holidays, click the Setting menu and select Holidays. To add a new 
holiday, click Add. To modify an existing holiday, select the holiday entry and click 
properties. Change the value accordingly, and click OK. 
 

• How to setup allowances? 
 
To setup allowances, click the Setting menu and select Allowances. To add a new 
allowance, click Add. To modify an existing allowance, select the allowance entry and 
click properties. Change the value accordingly, and click OK. 
 

• How to setup shifts? 
 

To setup shifts, click the Setting menu and select Shifts. To add a new shift, click 
Add. To modify an existing shift, select the shift and click properties. Change the 
value accordingly, and click OK.  
 

• How to setup shift patterns? 
  
To setup shift patterns, click the Setting menu and select Shift Patterns. To add 
a new pattern, click Add. To modify an existing pattern, select the pattern and click 
properties. Change the value accordingly, and click OK.  
 

• How to setup leave patterns? 
  
To set/modify leave patterns, click the Setting menu and select Leave Patterns. 
To add a new pattern, click Add. To modify an existing pattern, select the pattern and 
click properties. Change the value accordingly, and click OK. 
 

Note: After you modify these settings, you need to re-roster the employees if they ought to 
use on the new setting (For example, if they ought to work on the newly modified shift). 
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2.3 Logging In 
 
• How do I login to the software? 

 
Start Smart Time (the shortcut is usually located at Start > Programs > TMM 
Software > Smart Time). At the login screen, type in your user name and password 
then click the login button. If you are running Smart Time for the first time, the default 
user name and password are admin and admin. Click Cancel if u wish to quit the 
program. 
 

• I don’t have user name and password, can I use the software? 
 
No. Contact your system administrator or your software vendor to get your user name 
and password. 
 

• I type the correct login name and password, but it said the password 
did not match or user not found. What can I do? 
 
Please check your Caps Lock and Num Lock, make sure it is off. If it still does not 
solve your problem, please contact your system administrator or your software vendor. 
 

• A screen shown that my software about to expire, what can I do? 
 
You can still login and use the software. But please contact your system administrator 
or your software vendor to renew your software license to avoid service interruptions. 
 

• My software is expired. I cannot login. What can I do? 
 
Contact your system administrator or your software vendor to renew your software 
license. 
 

• I am sure that my software will only expire next year, but now it show 
that it is expired. What’s wrong? 
 
Please check your Microsoft Windows system date (go to Control Panel > Date 
and Time), make sure the date is correct. If it still does not solve your problem, 
please contact your system administrator or your software vendor. 
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2.4 Organization 
 
• How do I open the Organization Explorer? 

 
Click at menu View > Organization Explorer. Or, use the shortcut toolbar, click 
at Organization button. 
 

• What can I do with the Organization Explorer? 
 

At the Organization Explore, you can add, modify, or remove divisions 
and employees in the software. Other employee-based functionality such as 
leave management, roster generation, etc is also available here. 

 
• How many divisions and employees I can add to the software? 

 
There is no known limitation in the software. But as the number of employees increase, 
the software speed performance drops, depends on the capacity of your database 
server. 
 

• How do I add a division? 
 
Open the Organization Explorer. At the left hand side of the screen there are 
three tab pages. Select Division. Select and right click at the division tree box and 
select add division. A New Division will appear in the box. Select and right click the 
newly added New Division and select Division Properties. Chance the new 
division properties at the popup screen. 
 

• How do I move a division to another division? 
 
Select and right click the division and select Division Properties. Click the … 
button and select the target division. 
 

• How many levels of sub-division I can create? 
 
There is no known limitation in the software. 
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• How do I delete a division? 
 
Select and right click the division and select Delete Division. Click yes if you are 
sure to delete the division.  
 
After delete, the division will be moved to a special division named Deleted Items. 
At this point, the historical data/reports for this division are still available. 
 
If you want to delete a division permanently, under the Deleted Items node, select 
and right click the division and select Delete Division. Click yes if you are sure to 
delete the division permanently. After this, all historical data/reports for this division are 
no longer available. 
 
Note: If you deleted a division, all employees in the division will be deleted too.  
 
 

• How do I restore a deleted division or employee? 
 
You can restore a division or employee if it is not permanently deleted. To restore a 
division or employee in the Deleted Items: 
 
1. In the Organization Explorer, select the node Deleted Items at the tree list. 
2. Here you will see all the deleted divisions or employees. To restore a division or 

employee, right click it, and then select Division Properties or Employee 
Properties. 

3. Click the … button and select the target division to restore to. 
4. Refresh the list (context menu > Refresh). 
 

• How do I add an employee? 
 
Right click the employee list box then select Add Employee. Double click the newly 
added employee (named New Employee) to call out the Employee Properties 
dialog. Here you can modify the ID, name, division and other settings. 
 

• How can I delete an employee? 
 
Right click the employee list box then select Delete Employee. Click yes if you are 
sure to delete the employee.  
 
After delete, the employee will be moved to a special division named Deleted Items. 
At this point, the historical data/reports for this employee are still available. 
 
If you want to delete an employee permanently, under the Deleted Items node, 
select and right click the employee and select Delete Employee. Click yes if you are 
sure to delete the employee permanently. After this, all historical data/reports for this 
employee are no longer available. 
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• What are Folders? 
 
Folders let you categorize employees in the way you want. To use the folders, open the 
Organization Explorer. At the left hand side of the screen there are three tab 
pages. Select Folders.  
 

• How do I put employees into a folder? 
 
Open the Employee Properties dialog, under Settings tab, check the folders you want to 
put this employee to. 
 

• How do I generate roster automatically? 
 
Select and right click the employees and select Generate Roster. This feature lets 
you generate roster for employees automatically according to the Shift Patterns 
the employee is assign to. Select the date range you want to generate and click OK 
button. 
 

• How can I print or export the employee list? 
 
To print the employee list: Select all employees you wish to print, and right click it. 
Select Print Selected Record and select your paper size. A print preview screen 
popup. Click Print Report to print it. 
 
To export the employee list: Select all employees you wish to export, and right click it. 
Select Export Selected Record and select Text File. Select the filename and 
save it. 
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2.5 Rostering 
 
• How do I open the Roster Explorer? 

 
Click at menu View > Roster Explorer. Or, use the shortcut toolbar, click at 
Roster button. 
 

• How do I see the roster for each department? 
 
Open the Roster Explorer, select the division, set the date range and click the 
Search button.  
 
The Draft View tab let you modify the roster easily. Select a grid box and right click 
for more options. 
 
The Over View tab displays the rostering information at a glance. You can choose to 
display different information by selecting the option at the Show option. 
 
The Details View tab displays the rostering details information for every record. 
 
The Summary View (the bottom of the screen) display summary information of the 
selected data range. 
 

• How can I see the hours work in the roster? 
 
Click the Over View tab and click the drop down menu to select options you want. 
 

• How can I change the roster? 
 
Click the Draft View tab and select cell you wan to change. Right click the cell and 
change the roster. 
 

• How can I clear the entire roster? 
 
Click the little box on the Emp ID and right click it. Select Clear shift. 
 

• How can I change the detail values of the roster? 
 
Go to Draft View and double click the cell. You can change the value at General 
tab. 
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2.6 Time Keeping 
 
• How do I open the Time Keeping Explorer? 

 
Click at menu View > Time Keeping Explorer. Or, use the shortcut toolbar, click 
at Time Keeping button. 
 

• How do I see the time keeping for each department? 
 
Open the Time Keeping Explorer, select the division, set the date range and click 
the Search button.  
 
The Over View tab displays the time keeping information at a glance. You can choose 
to display different information by selecting the option at the Show option. 
 
The Details View tab display the time keeping details information for every record. 
 
The Raw Punching Log displays the actual raw (un-analyzed) punching log. 
 
The Summary View (the bottom of the screen) display summary information of the 
selected data range. 
 

• What is Match, Unknown, Critical, Incomplete and Unplanned OT? 
 
Match – Employee punched in and out on time according to roster. 
Unknown – Employee punched in and out without roster or changed shift without roster. 
Critical –Either employee came to work late or leaved early. 
Absent – Employee did not punch in and out. 
Incomplete – There is only single punching data (either in or out) captured within the 
sensitivity. 
Unplanned OT – Employee worked on unauthorized OT. 
 

• What does “???” mean? 
 
Question marks mean no data was captured. 
 

• How do I authorize the time keeping? 
 
Double click on a record to call out the Time Keeping Properties dialog. Alter the 
hours worked (Regular, OT, OP and Recall hours). You can also click on Pay As 
Rostered to set the hours as rostered. Click OK to confirm the changes. 
 

• I already imported data, why it still displays all employees as absent? 
 
After imported data from server, you need to analyze it. Click Analysis button to 
analyze the data. Also, make sure that the date range setting is correct when you 
import the data. 
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• How can I assign an allowance to a particular shift? 
 
Double click the record and select Allowance tab. Add or check the allowance your 
want to assign to the shift. 

• An employee was unable to punch in due to technical faulty. It shows 
absent at the time keeping. What can I do? 
 
You can add a punch for the employee. Right click the screen and select Add.  Select 
the date, time and punching type and click Punch. Click Search again, you should be 
able to see the new records there. 
 

• The employee was absent yesterday and now he requests an annual 
leave for that day. How do I apply leave for him? 
 
Go to Organization Explorer and search for the employee. Right click his name 
and select Leave Manager. Apply the leave with the desire parameters on the screen. 
After you apply the leave, the Absent record for that employee on that day will be 
disposed. If you apply for a half day leave, make sure the leave duration covers the 
absent duration. 
 

• How do I see the summary for a portion of records? 
 
Select the records and you want to see the summary (use the Shift or Ctrl key on 
your keyboard). Right click them and select Calculate Summary. 
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2.7 Reporting 
 
• How do I open the Reports Explorer? 

 
Click at menu View > Reports Explorer. Or, use the shortcut toolbar, click at 
Reports button. To view a report, select the report node on the tree list, adjust the 
parameter and click View Report. 
 

• I tried to print the report, but my paper was unable to fit in. What can 
I do? 
 
Try printing the report in Landscape or large paper size. 
 

• The report preview looks OK, but the layout of the printed report is 
messy. What’s wrong? 
 
Make sure your Paper Setup is correct. On the preview window, click Paper Setup 
button. On the popup dialog, make sure the paper size is correct. Clear any text on the 
Header and Footer text box. Make sure all margins are set to 0.6 inc. Make sure the 
paper orientation is correct. Click OK and print the report again. 
 

• How do I redistribute the reports? 
 
The reports generated are coded in HTML format, and thus it is very easy to 
redistribute them, even publish to the Internet. To do so, preview the report, click at 
Save As button. Type in the file name and click Save. At the target folder where you 
save the file, you will be able to see a newly created .html file and a folder with the 
same name. You can safely distribute the report by copying this file and folder together. 
To view the report, simple double click on the .html file. 
 

• The reports are interesting, can I add more report into the software? 
 
Contact your software vendor to ask for customization. We are ready to customize the 
reports for you. 
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2.8 Database Maintenance 
 
• How to backup or restore database? 

 
Go to Administration > Backup/Restore Database. Make sure the parameter 
is correct, select a backup path and click Backup or Restore. 
 

• How to purge/archive database? 
 
Go to Administration > Purge/Archive Database. Select a date range and 
click Purge or Archive. The purged data is no longer available in the software. To 
view these data, you need to archive them first,  
 

• How does the Database Auto Backup work? 
 
Database base Auto Backup (Administration > Database Auto Backup), if 
enable, will backup the database daily automatically. You can then restore the database 
to a specific date if something goes wrong. You can keep as many history databases as 
you like, provided you have enough hard disk space. To restore the database, select a 
restore point (date) and click Backup. 
 

• What routine database maintenance does? 
 
You should run the database maintenance (Administration > Database 
Maintenance) regularly. It checks for missing links, checks & repairs database table, 
and other database maintenance tasks. 
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3 Forms Instructions 
 
Note: If some of the items (such as buttons, menu, check boxes) on a form has been 
disabled, you probably did not have the privilege to use the corresponding feature. Contact 
your system administrator or your software vendor for more information. 
 
3.1 Main 
 
3.1.1 Import Time Attendance Data 
 

 

Use this form to import time attendance 
data from the punching device.  
 
1. Select the device where you want to 

import data from.  
2. Specify the date range where you want 

to import the data. If you are not sure 
about the date range, just accept the 
default value.  

3. Click Import Now to start the importing process. This may take several minutes 
depends on the data load.  

4. After importing you should be able to see these data at the Raw Punching Log in 
Time Keeping Explorer.  

 
Note: The imported data is no yet analyzed. To analyze the data please select menu Main > 
Analyze Time Attendance Data. 
 
3.1.2 Run Time Keeping Analysis 

 

 

Use this form to analyze time attendance data imported 
from a punching device.  
 
1. Select option Run all unprocessed data if you 

want to analyze all newly imported data from a 
punching device.  

2. Select option Run for date range if you want 
to analyze only a specific range of data.  

3. Click Run Now to start the analysis process. This 
may take several minutes depends on the data 
load.  

 
After analysis you should be able to see the result in Time Keeping Explorer.  
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3.1.3 Export Time Keeping Data 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Use this form to export 
employees' time attendance 
data for selected date range to 
an interface text file, or to a 
database.  
 

1. Click on ... button to select employees to export.  
2. Select the date range to export.  
3. Select option Export To Text File if you want to export the data to an interface 

text file.  
4. Select the format you want for a date/time value. 5 different formats are available: dd 

MMM yyyy hh:mm tt, dd-MM-yy hh:mm tt, dd-MM-yy HHmm, ddMMyyHHmm 
and time stamp (in minute) since 1st January 1 00:00.  

5. Select the format you want for a duration value. 3 different formats are available: 
literal string, hour fraction and total minutes.  

6. Select the path where you want to save the text file to.  
7. If the selected text file already contains some data, the program will write the new data 

to the end of the file. The program will not check for data duplication before writing. If 
you export the same data twice, the text file will contain duplicated data.  

8. Select option Export To Database if you want to export the data to a database. The 
program come with a blank database located at  

 
[Installed Path]/database/TK.mdb 
 
for this export purpose. You can move this file to another location if you want. Point the 
Database field to this file. The program checks for data duplication before writing, and 
replace the older data if found.  

9. Click OK to start the exporting process. This may take several minutes depends on the 
data load.  
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3.2 View 
 
3.2.1 Organization Explorer 
 

 
 
Use this form to manage the divisions, employees and employee categories of your company. 
 
To Add a Division  
 
1. Select the Divisions tab.  
2. There is a root item in the division tree list displaying your company name. Select and 

right-click on this item and select Add Division from the popup menu.  
3. Select and right-click on the newly added division (usually named New Division) and 

select Division Properties from the popup menu. Modify the division properties 
as you want.  

 
To Modify a Division  
 
1. Select the Divisions tab.  
2. Select and right-click on the division which you want to modify and select Division 

Properties from the popup menu. Modify the division properties as you want.  
 
To Delete a Division  
 

1. Select the Divisions tab.  
2. Select and right-click on the division which you want to delete and select Delete 

Division from the popup menu.  
 
All sub-divisions will also be deleted. All employees under the deleted division and any sub-
divisions will be moved to Deleted Items.  
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To Add a Folder  
 
1. Select the Folders tab.  
2. There is a root item in the folder tree list displaying your company name. Select and 

right-click on this item and select Add Folder from the popup menu.  
3. Select and right-click on the newly added folder (usually named New Folder) and 

select Folder Properties from the popup menu. Modify the folder properties as 
you want.  

 
To Modify a Folder  
 
1. Select the Folders tab.  
2. Select and right-click on the folder which you want to modify and select Folder 

Properties from the popup menu. Modify the folder properties as you want.  

 
To Delete a Folder  
 
1. Select the Folders tab.  
2. Select and right-click on the folder which you want to delete and select Delete 

Folder from the popup menu.  
 
To Add an Employee  
 
1. On the employee list view (right portion of the window), right-click and select Add 

Employee from the popup menu.  
2. Right-click on the newly added employee (usually named New Employee) and select 

Employee Properties from the popup menu. Modify the employee properties as 
you want.  

 
To Modify an Employee  
 
Right-click on the employee which you want to modify and select Employee Properties 
from the popup menu. Modify the employee properties as you want.  
 
To Delete an Employee  
 
1. Right-click on the employee which you want to delete and select Delete Employee 

from the popup menu.  
2. Deleted employees will be moved to Deleted Items.  
 
To Restore an Employee  
 
1. Select the Divisions tab.  
2. There is an item in the division tree list called Deleted Items. Click on this item.  
3. The employee list view (right portion of the window) will display a list of deleted 

employees. Right-click on the employee which you would like to restore and select 
Employee Properties.  

4. Reset the employee's Division property to his/her original division.  
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To Apply For Leave  
 
Right-click on the employee you would like to apply leave for and select Leave Manager 
from the popup menu.  
 
To Generate Roster for an Employee  
 
1. This function lets you generate the roster for employees according to the employees' 

Shift Pattern setting. Before you proceed please make sure that this setting is 
done correctly.  

2. Right-click on the employee you would like to generate roster for and select Generate 
Roster from the popup menu.  

 
To Copy Roster for an Employee  
 
1. This function lets you copy the roster for employees from a specific date range to 

another.  
2. Right-click on the employee you would like to copy roster for and select Copy Roster 

from the popup menu.  
 
3.2.1.1 Division Properties 
 

 
 
Use this form to modify the division properties.  
 
1. Enter the division Name of the division.  
2. Click on the ... button to select a parent division of the division. A parent division is 

the division which owns the currently selected division.  
3. The Remark field is optional.  
4. Click OK to confirm the changes.  
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3.2.1.2 Folder Properties 
 

Use this form to modify the 
folder properties.  
 
1. Enter the folder Name of 

the folder.  
2. Click on the ... button to 

select a parent folder of 
the folder. A parent folder 
is the folder which owns 
the current folder.  

3. The Remark field is optional.  
4. Click OK to confirm the changes.  
 
3.2.1.3 Employee Properties (single) 
 

 
 
Use this form to modify the employee's properties for a single employee.  
 
Details Tab  
 
1. Enter the employee's details as stated on the form. All fields are optional except 

Employee ID and Employee Name.  
2. The Employee ID can contain any characters including alphabetical characters (a~z), 

numbers (0~9) and hyphen (-).  
3. The Exists in folder(s) option lets you define which folder the selected 

employee exists in. An employee can exists in more than one folder.  
4. To change the picture of the employee, click on the picture box (upper-left). Browse to 

and select the picture you want to use. The software will duplicate a copy of the picture, 
meaning that you can safely remove the original picture after this.  
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Settings Tab  
 
1. Enter the employee's settings as stated on the form. All fields are optional except 

Accessibility.  
2. Please make sure that you have setup the Work Hour Rules, Shift Patterns, Leave 

Patterns correctly otherwise these options will not be available here.  
3. The ID From Punching Device is the ID this employee will be used to punch on 

the punch device. It can contain any characters including alphabetical characters (a~z), 
numbers (0~9) and hyphen (-).  

4. The Accessibility option lets you define which user(s) is able to view/modify this 
employee. If you want to allow all users to have access to this employee, check 
Everyone.  

5. To change the Leave Pattern Starting Date, select the date and then click Reset 
button below the date picker box. This will reset the leave summary data (available, 
forfeit, etc) of the selected employee. These data will be re-calculated according to the 
employee's Leave Pattern setting. It will not affect the employee's leave history, 
however.  

 
Leave Summary Tab & Leave History Tab  
 
These tabs display the leave leaves information of the selected employee.  
 
Click OK to confirm the changes.  
 
3.2.1.4 Employees Properties (multiple) 
 

 
 
Use this form to modify the employees' properties for a multiple employees.  
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Details Tab  
 
1. Enter the employees' details as stated on the form. All fields are optional.  
2. The Exists in folder(s) option lets you define which folder the selected 

employees exist in. An employee can exists in more than one folder.  
3. Choose Add to employees' folder setting if you only want to add folder(s) to 

the employee and remain their original folder settings, otherwise choose Completely 
replace employees' folder setting if you want the current folder setting 
replace their original setting.  

 
Settings Tab  
 
1. Enter the employees' settings as stated on the form. All fields are optional except 

Accessibility.  
2. Please make sure that you have setup the Work Hour Rules, Shift Patterns, Leave 

Patterns correctly otherwise these options will not be available here.  
3. The Accessibility option lets you define which user(s) is able to view/modify the 

selected employees. If you want to allow all users to have accessibility to the selected 
employees, check Everyone.  

4. Changing the Leave Pattern Starting Date will reset the leave summary data 
(available, forfeit, etc) of the selected employees. These data will be re-calculated 
according to the employees' Leave Pattern setting. It will not affect the employees' 
leave history, however.  

 
Click Apply button next to each option which you have modify to confirm the changes.  
 
3.2.1.5 Leave Manager 
 

 
 

Use this form to apply a leave or entitle/deduct leave bonus for employee(s). 
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To Apply For Leave  
 
1. Select the leave type and date for the leave application.  
2. Make sure the leave Pattern setting for the selected employee(s) has setup 

properly and that he/she is entitled to the selected leave type.  
3. Enter the leave hours for this application. This value will be used to calculate the total 

leave hours taken in the Time Keeping.  
4. The leave summary Taken value will be deducted 0.5 if you choose Half Day, and 

1.0 if you choose Full Day.  
5. Click Apply to confirm the application.  
 
To Entitle/Deduct Leave Bonus  
 
1. Select the leave type you want to entitle/deduct.  
2. Make sure the leave Pattern setting for the selected employee(s) has setup 

properly and that he/she is entitled to the selected leave type.  
3. Enter the quantity you want to entitle/deduct. The quantity must be a positive number, 

and can be a floating number. E.g. 0.5.  
4. The Reason field is optional.  
5. Click Entitle to entitle the leave bonus, or Deduct to deduct from the leave bonus.  
 
3.2.1.6 Generate Roster 
 

Use this form to generate roster automatically 
according to Shift Pattern setting for employee(s).  
Make sure you have setup the employees' Shift Pattern 
properly.  
 
1. Select the date range where you want to 

generate roster for the selected employee(s).  
2. The program will not generate roster for days 

before the Shift Pattern Starting Date.  
3. Click OK to begin the process.  

 
3.2.1.7 Copy Roster 

 
Use this form to copy existing 
roster to another date range for 
employee(s).  
 
1. Select the date range where 

you want to copy existing 
roster from.  

2. Select the starting date 
where you want to copy the 
roster to.  

3. Click OK to begin the 
process.  
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3.2.2 Roster Explorer 
 

 
 
Use this form to manage shift roster of employees in your company. 
 
To add a shift 

 
1. Select the Draft View tab. 
2. Select the division and date range and click Search. 
3. There are a lot of grid boxes in the list. Select and right click the grid box and select the 

shift you wish to add. 
 
To view or modify a shift details 
 
1. Select the grid box you want to modify. 
2. Right-click the grid box and select Properties from the popup menu. 
3. Modify the division properties as you want. 
 
To delete a shift 
 
1. Select the grid box you want to delete 
2. Right-click the cell and select Clear Shifts from the popup menu. 
3. The deleted shift will not be able to restore after you clear it. 
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To copy and paste a portion of roster 
 
1. This function let you copy and paste a portion of roster from a date range to another. 
2. Use your mouse to highlight the grid boxes you wish to copy (click and drag). 
3. Right-click the highlighted area and select Edit > Copy Selected Grids. 
4. Use your mouse to highlight the grid boxes you wish to paste (click and drag). Make 

sure you select the same grid dimension. 
5. Right-click the highlighted area and select the Edit > Paste Copied Grids. 
 
 
3.2.2.1 Roster Properties (single) 
 

 
 
Use this form to modify the roster properties for a single shift entry. 

 
General Tab 
 
1. Enter the general details as stated on the form. 
2. These parameters are similar to Awards Rule parameters. Please refer section 

3.3.2.1 Awards Rule Properties for more information. 
 
In Entry Tab and Out Entry 
 
3. Enter the In entry and Out entry parameters as stated on the form. 
4. These parameters are similar to Shift parameters. Please refer section 3.3.5.1 Shift 

Properties for more information. 
 
Allowances Tab 
 
1. Check the allowances you wish to assign to the shift. 
2. You can also add additional allowances for the shift. Enter the allowance name and 

then click the Add button. 
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Misc. Tab 
 
1. Type in the new shift name in the form if you want to change the shift name. 
2. Enter the duration of break time you wish to assign to the shift. 
3. The break time will deducted from the shift work hour. 
4. You can ignore the hours work before or after the shift. No OT hours will be calculated 

if you checked both options. 
 
 

3.2.2.2 Roster Properties (multiple) 

 
 

 
Use this form to modify the roster properties for a multiple shift entries. All the fields are 
same as section 3.2.2.1. Click Apply button on each field to confirm the changes. 
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3.2.3 Time Keeping Explorer 
 

 
 
Use this form to view the time keeping result. Note: you only able to view the result after 
you import data from server and analyze it. Else, all data will be absent 
 
To add a punch 
 
1. Right click the list in Over View or Detail View and select Add. 
2. Select the Employee, Date, Time and Punch Type. 
3. Click Add. Note: Only authorized personal able to add punch. 
 
To modify a record  
 
1. Right click the record in Over View or Detail View and select Properties. 
2. Modify the record as you wish and click Apply or OK. 
3. Click Search to refresh the list. 
 
To delete a record 
 
1. Right click the record in Over View or Detail View and select Delete. 
2. Click Yes if you are sure to delete the record. This will only remove the time 

attendance information. To remove the roster information as well, do so at Roster 
Explorer. 

3. Click Search to refresh the list. 
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To calculate summary 
 
1. Hold down shift or Ctrl key and select the records you want. 
2. Right click the records and select Calculate Summary. 
3. If you only select a single record, summary of all the records will be calculated. 
 
To print records or summary 
 
1. Hold down shift or Ctrl key and select the records you want. 
2. Right click the records and select Print Selected Records > Using [paper 

size]. 
 
To export records or summary 
 
1. Hold down shift or Ctrl key and select the records you want. 
2. Right click the records and select Export Selected Records > Text File. 
3. Select the location of the file and click Save. 
 
3.2.3.1 Time Keeping Properties (single) 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Use this form to 
modify employee’s 
time keeping 
information for a 
single shift entry. 
 

Date & Time Tab 
 
1. Enter the Regular Hours, OT Hours, OP Hours and Recall for the employee. All 

units are in Hour. 
2. Click Set As Rostered to set these hours following the roster. 
3. Click Re-Calculate to recalculate the hours according to the settings for you. 
4. If the employee was absent, type the absent reason in the text box. The reason will be 

printed on the reports. 
5. You can modify the actual punch time of the employee at the group Date & Time. 
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Allowances Tab 
 
1. Check the allowances you wish to assign the employee for this shift. 
2. You can also add additional allowances to this shift. Enter the allowance name and then 

click the Add button. 
 
3.2.3.2 Time Keeping Properties (multiple) 
 

 
 
Use this form to modify the time keeping properties for a multiple shift entries. All the fields 
are same as section 3.2.3.1. Click Apply button on each field to confirm the changes. 
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3.2.4 Report Explorer 
 

 
 
Use this form to navigate the available reports collection. Select the report from the left hand 
tree list, select the options, and click View Report. A print preview window popup. Before 
printing the report, make sure that the paper settings are correct. Click at Paper Setup 
button to change the paper settings. 
 
3.2.5 Activity Log Browser 
 

 
 
Use this form to keep track of users’ activities. Select a date range and user name (blank to 
search all) and click Search. You can alter the logging settings at the Preferences form 
(Section 3.3.8). 
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3.3  Settings 
 
3.3.1  Company Information 

 
Use this form to modify your 
company information 
 
1. Fill in all information in the 

form. Some information 
might appear in the reports. 

2. Only certain user can change 
the company name. 

3. Click on the empty box to 
insert your company logo 
(in .jpg format). 

 
 
 
 
 
 
 

3.3.2  Awards Rules 
 

 
 
Use this form to add, modify 
and delete working rules. 
 
To add new rule. 
 
1. Click the Add button to 

add new rule 
2. “New Rule” will appear 

in the list. 
3. Select the “New Rule” 

double clicks it or clicks 
the Properties to 
modify the new rule. 

 
 
To modify an existing rule. 
 
1. Select and click the rule name 
2. Double click the rule or click the Properties button. 
 
To delete a rule. 
1. Select the rule name you wish to delete 
2. Click the Delete button. 
3. Click Yes to confirm delete. 
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3.3.2.1  Awards Rule Properties 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Use this form 
to modify the 
day type’s 
work hour 
rule. 
 

To add a new work rule 
 
1. Day Type, Week Day and Holiday describe the attribute of the day. 
2. Max. Regular Hour, Min OT Hour and Max OT Hour describe the hours can 

work in the day. 
3. Click Add after finish fill in all field. 

 
To modify work rule 
 
1. Day Type, Week Day and Holiday describe the attribute of the day. 
2. Max. Regular Hour, Min OT Hour and Max OT Hour describe the hours can 

work in the day. 
3. Click Update after finish change all field. 
 
To delete work rule 
 
1. Select the work rule in the list 
2. Click Delete button. 
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3.3.3  Holidays 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Use this form to 
manage all holidays 
 

To add a holiday 
 
1. Click Add button to add a holiday 
2. “New Holiday” will appear in the list 
3. Double click it to modify it. 

 
To modify a holiday 
 
1. select the holiday from the list 
2. double click or select Properties 
3. change the holiday settings and click OK 
 
To delete a holiday 
 
1. Select the holiday from the list 
2. Click Delete button 
3. Click Yes to confirm delete the holiday 
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3.3.3.1 Holiday Properties 
 

 
Use this form to change the 
properties for holiday 
 
1. Type in name and 

description of the holiday 
2. If the holiday is different 

date every year then 
select variable 

3. If the holiday if fix for 
every year or month then 
select Fix and assign the 
date. 

4. Click Ok to update. 
 
 
 
 
 

 
3.3.4  Allowances 
 

Use this form to manage 
the allowance 
 
To add an allowance 
 
1. Click the Add button. 
2. A “New 

Allowance” will 
appear in the list. 

3. Double click to 
modify it. 

 
 
 
 
 
 

To modify an allowance 
 
1. Select the allowance the you wish to modify 
2. Double click or click the Properties button 
3. Change the allowance setting and click Ok 
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3.3.4.1  Allowance Properties 
 

 
Use this form to change the name and 
description of the allowance 
 
1. Type in the new name and description of 

the allowance. 
2. Click Ok. 
 

 
3.3.5  Shifts 

 
 
 
 
 
 
 
 
 
 
 
Use this 
screen to 
manage shift 
for employees. 

 
To add a shift 
 
1. Click the Add button 
2. A “New Shift” will appear in the list 
3. Select it and click Properties. 
4. And define the shift settings 
 
To modify a shift 
 
1. Select the shift you wish to modify 
2. Select Properties or double click on it 
3. Define the shift settings 
4. Click Ok to save new settings 
 
To delete a shift 
 
1. select the shift you wish to delete and click Delete 
2. You will see a confirm screen popup 
3. Click Yes if you confirm to delete the shift 
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3.3.5.1  Shift Properties 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Use this form to 
change the 
properties of the 
shift. 
 

In Entry tab 
 
1. Type in the work start time in Roster Time 
2. Punch Capturing Rules are rules to capture punch before and after the working 

time. 
3. Fill in how many minutes you wish to capture the punch before and after the Roster 

Time. 
4. You can either Use the earliest punch or latest punch within the sensitivity. 
 
Out Entry tab 
 
1. Type in the work end time in Roster Time. 
2. Punch Capturing Rules are rules to capture punch before and after the working 

time. 
3. Fill in how many minutes you wish to capture the punch before and after the Roster 

Time. 
4. You can either use the earliest punch or latest punch within the sensitivity 

 
Misc. Tab 
 
1. Type in the new shift name in the form if you want to change the shift name. 
2. Enter the duration of break time you wish to assign to the shift. 
3. The break time will deducted from the shift time. 
4. You can ignore the hours work before or after the roster. No OT will calculate if you 

checked both options. 
5. Click Apply after u change every field. 
 
Allowances Tab 
1. Select the preset allowances you wish to assign to the shift. 
2. You are able to add additional allowances for the shift by filling in the allowance name 

and amount then click the Add button. 
3. Click Apply after u change every field. 
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3.3.6  Shift Patterns 
 

  
 
 
 
Use this form to define the shift 
pattern 
 
To add a pattern 
 
1. Click Add to add new shift 

pattern 
2. “New Shift Pattern” 

will appear in the list 
3. Select it and click 

Properties to change 
the settings. 

 
To modify a shift pattern 
 
1. Select the shift pattern and click Properties 
2. Change the setting and click OK. 
 
To delete a shift pattern 
 
1. Select the shift you wish to delete 
2. Click Delete button 
3. Click Yes to confirm delete. 
  
3.3.6.1  Shift Pattern Properties 
 

 
Use this form to change 
the pattern type 
 
1. Type in the Day 

Number 
2. Select the Day Type 

and the Shift 
3. You can define the 

pattern as many days 
as you like 

 
 
 
 
 
 
 
 



44  

3.3.7  Leave Patterns 
 

 
 
 
 
 
Use this form to add or delete 
leave pattern form every 
employees 
 
To add new leave pattern 
 
1. Click Add button to add new 

leave type 
2. You will see “New 

Pattern” in the list 
3. Select it and click 

Properties to change the 
leave option 

4. Click Ok to save the settings 
 
To modify a leave pattern 
 
1. Select the leave from the list 
2. Double click it or click the Properties 

button. 
3. Change the options and click Ok to 

save settings. 

To Delete a leave pattern 
 
1. Select the leave pattern you wish to 

delete. 
2. Click the Delete button. 
3. Click Yes if you confirm to delete the 

leave type. 
 
3.3.7.1  Leave Pattern Properties 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Use this form to manage 
all leave type in your 
company. 
To add new leave type 
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1. Click Add button to add new leave type 
2. You will see “New Leave” in the list 
3. Select it and click Properties to change the leave option 
4. Click Ok to save the settings 
 
To modify a leave type 
 
1. Select the leave from the list 
2. Double click it or click the Properties button 
3. Change the options and click Ok to save settings 
 
To Delete a leave type 
 
1. Select the leave you wish to delete. 
2. Click the Delete button 
3. Click Yes if you confirm to delete the leave type 
 
3.3.7.1.1  Leave Type Properties 
 

 
 
Use this form to assign the settings for every leave 
 
1. Define the day of leave can be bring forward. The system will automatic bring forward 

the leave after a pattern cycle. 
2. You can use monthly earning pattern to define how many days of leave can earn for an 

employee in every month 
3. Enter the number of month in the text box and click the Reset button 
4. Enter the value for every month 
 
 



46  

3.3.8  Preferences 

 
 
General Tab 
 
1. Picture Folder is the folder location to store all pictures. You can change the path 

to a network folder too if you are using a network version. 
2. Check to enable the activities log and select the day range. 
3. If you wan the system automatic round the Match Record As Roster, check the 

second checkbox.  
4. To remove absent record from the time keeping, check the third checkbox. 
5. Check the ignore punches between shift-in-out entries checkbox to remove extra 

punches that occur in a day. 
6. The mid night cut off time and allow user to modify roster parameters enable 

user to change the cut off time in minutes and how many days the roster would not 
allow to be modify again. 

7. The hour display format includes various date and time format to be shown in 
system. 
 

 

Use this form to change the 
setting of the software. 
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3.4 Administration 
 
3.4.1 Users Settings 

 
 
Use this form to manage the user 
to use the system. 
 
To Add User 
 
1. Click the Add button 
2. Type in the User Name and 

Password in the form 
3. Verify and type the password 

in Verify Password field. 
4. Please remember your 

password for future login 
 
 

 
To change or modify a user access 

 
 
1. Select the user name 
2. Double click or select 

the Properties 
button 

3. You can manually 
change the user 
access or use the 
pre-set access. 

4. Click Ok to save 
settings. 
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3.4.2 Backup/Restore Database 
 

 
 

Use this form to backup and restore database anytime you want. This is a manual backup 
and you can backup it in any store devices. 
 

1. Fill in the Parameters. The syntax is <Primary Database 
Path/Name>;<Secondary Database Path/Name>.  
For example, if you are using MS Access, parameter may be 
C:\Database\db.mdb;C:\Database\db_s.mdb; 
If you are using MS SQL Server, parameter may be 
primary_database_name;secondary_database_name; 

2. Click Save Settings to save the settings you have change. 
3. Backup Path is the destination path. Click the … to select the destination. 

 
3.4.3 Database Auto Backup 
 

 
Use this form to set auto backup 
for the software. You can use 
restore points to undo harmful 
change this system and restore its 
setting and performance.  
 
Auto Backup 
 
1. Fill in the day’s value and the 

Backup Path. 
2. Click Save Settings 
3. Your system will 

automatically create restore 
point. 

 
Restore Points 
 
1. You can use the restore date to roll back your previous database. 
2. Select the Date and click Restore. 
3. It is highly recommended to restart the software after restore. 
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3.4.4 Purge and Archive Database 
 

 
 

Use this form to purge or archive the database. Purging will transfer old/unused data from 
the primary to secondary database. This will speed up the software performance. If you 
want to access the purged data, you need to archive them from secondary back to primary 
database. 
 
1. Select the date range you want to purge or archive. 
2. Click Purge Now or Archive Now. 
 
3.4.5 Punching Device Setting 
 

 
 
 
Use this form to 
manage the punching 
device’s back-end 
software which will be 
connected to this 
program. The program 
will connect to the 
specified software to 
download the 
punching data when 
use click on Import 
Time Attendance 
Data. 

 
To add a new device 
 
1. Click Add button. You will see “New Device” appear in the list 
2. Select the “New Device” and click properties to change the settings 
3. Click Ok to save settings. 
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To modify a device 
 

 
 
1. Select the device you wish to modify 
2. Click properties or double click the device name. 
3. Select the device Type from the drop down menu. 
4. Fill in the parameters. The syntax of the parameter is <Back End Database 

Path>;<1= In/Out or 2=Location code>;<In code>;<out 
code>;<Casual In code >;<Casual Out code>;<2 for 24 hours / 1 
for 12 Hours>;<Location code>|<Device Location name >|; 

5. Type in a simple Description 
6. Click Ok to save settings. 


